iLab European Site Unavailable Thursday, February 15th, 2018 03:00:00 EST


EU Network issues:

Resolved - iLab would like to inform you that the network issue in our EU sites have resolved. Feb 15, 15:21 UTC

Investigating - We would like to inform you that currently we do experience a global issue in our EU sites. We will keep you infoermed of any updates. Feb 15, 15:14 UTC

EU Newtork issue:

Resolved - iLab would like to inform you that the network issue in our EU sites have resolved. Please accept our apologies for the caused inconvenience! Feb 15, 11:10 UTC

Investigating - Our System Administrators are working on it and we will update you in a timely manner. Feb 15, 10:55 UTC